Back to overview
Degraded
Communications Search Service Performance Degraded
Jun 17 at 01:43pm BST
Affected services
my.mirrorweb.com
Resolved
Jun 18 at 04:46pm BST
Search service has been restored, further optimisation work will continue but will not impact usage.
Affected services
Updated
Jun 17 at 04:48pm BST
Our engineers have identified the issue and implemented some mitigations whilst longer optimisations are running.
Affected services
Created
Jun 17 at 01:43pm BST
Our engineering team have identified search service performance degradation after this weekends database maintenance work. Our team are working on identifying and resolving the issue currently. Further updates will be provided here.
Affected services